SCVMM Self Serve Portal - multiple authentication requests when connecting to a VM (Full Version)

All Forums >> [Microsoft Virtualization] >> General



Message


garry -> SCVMM Self Serve Portal - multiple authentication requests when connecting to a VM (2.Feb.2010 5:50:23 AM)

Hello there,

I have successfully deployed SCVMM and find it a great tool for myself as an admin but also the portal will be very useful for our users.

The issue we're having is when successfully logged into the portal and clicking 'connect to VM' depending on what VMRC authentication is configured on the host (automatic / NTLM / Kerberos) we get a login box. For what its worth, when set to Kerberos, it always fails with 'authentication failure' Automatic tries Kerberos, fails then defaults to NTLM which works.

I'm assuming this is slowing down the connection to the VM firstly by trying the different authentication methods and secondly by prompting for the password every time. Even when we select to remember the password we are prompted every time.

We do not have to enter the password when we connect directly to the virtual server management page http://servername:1024. When set to Kerberos and connecting through the management page we see the following:

"The user "LAB05\Administrator" at Internet address x.x.x.x established a new connection to the VMRC server using Kerberos authentication"

So Kerberos does appear to be working at some level.

Can anyone give me any guidance at all? Being prompted for credentials every time a user connects is pretty much a deal breaker for rolling this out to our users.

Many thanks in advance,

Garry

EDIT - this does not happen when connectiing to a VM on our HyperV servers - only Virtual Server 2005




Page: [1]